MapTool Hex Grid in Photoshop

From Wiki of Worlds Unknown
Jump to: navigation, search

Use Cases

  • This tutorial is for those who have an existing map in MapTool and who want to do a bit more work on it in Photoshop while still being able to benefit from MapTool's grid in spite of Photoshop's inability to create a hex grid.
  • It can also be used if you plan to create a new map and already know the scale and dimensions of the map you'll ultimately be exporting. In this case, you'll want to export a blank grey image of the correct size from Photoshop and create a new map in MapTool from it before proceeding with this tutorial. It will act as a placeholder for when you have the map finished later.

Tutorial

Start out in MapTool...
  1. Get your hex grid set to the proper size and location relative to the map's background and set the color to white (255,255,255).
  2. On the Object Layer, draw a solid black rectangle covering the entire map. All you should see now is a white grid on a black background with no map showing.
  3. Zoom to 100%: View Menu-> Zoom-> Zoom 1:1
  4. Export a screenshot of the full map using the current GM view: File Menu-> Export-> Screenshot As... Type: Entire Map, Layers: Current View, View: GM
Switch to Photoshop...
  1. Open your original map AND the screenshot you just exported.
  2. In your screenshot, select the entire map (Ctrl+A) and then copy it (Ctrl+C).
  3. In your map file, create a new Fill Layer: Layer Menu-> New Fill Layer-> Solid Color.
  4. Name it whatever you like, keep the opacity at 100%. Pick whatever color you want the grid to be. The entire map should now be covered in that color.
  5. Select the new Layer.
  6. Switch to the Channels window: Window Menu-> Channels
  7. Select the Mask channel and make it visible (click the little show/hide box to the left of it so that a little eye appears in it)
  8. Paste. The screen will probably turn red, but you should see your grid.
  9. Hide the mask channel again and you should now see your hex grid looking just as nice as it does in MapTool.

Technical Explanation

The reason to use this method instead of copying the layer from the screenshot and using blending options you ask? Blending the areas on the grid layer that are black will either leave a short of greyish shadow around the white grid or make the already-thin grid lines even thinner. This method produces cleaner-looking results and eliminates the need to convert the grid layer into greyscale and apply a color overlay or adjustment layer.